Re: [PATCH 1/1] python/notmuch2: provide binding for database_get_directory()

Subject:Re: [PATCH 1/1] python/notmuch2: provide binding for database_get_directory()

Date:Mon, 26 Jul 2021 10:55:34 +0300

To:Ludovic LANGE ,notmuch@notmuchmail.org

Cc:

From:Tomi Ollila


On Sun, Jul 25 2021, Ludovic LANGE wrote:

// stuff deleted //

>  Le 25/07/2021 à 22:18, Floris Bruynooghe a écrit :

// stuff deleted ... //

>>
>> Anyway, I'm curious what other people think of this as well.
>
> Copy/paste (!!) of the previous bindings. As I don't know how people are
> using them, I was expecting to make as little changes as necessary, so
> that code change would be kept to a minimal when porting from old
> bindings to new bindings.

If such an implementation is more inconsistent w/ the new bindings, then
-- for sure -- have implementation that differs more from old bindings.
(and from copy-paste point of view, mistakes lurk easily if changes are
applied w/o doing even more careful post-inspection before committing...) 
>
> Waiting for other feedback also.
>
>
>>> +    def get_child_files(self):
>> Style-wise I'd name this `def files(self):`, I think it follows the
>> style of the API more.
>
> Same reasoning as before - not wanting to make too much changes from old
> to new bindings.
>
> But if the consensus is on having a new style, we will of course adapt.

IMO the def files(self): (and def directories(self):) are the way to go !

Tomi

// stuff deleted //

>
> Regards,
>
> Ludovic
>
_______________________________________________
notmuch mailing list -- notmuch@notmuchmail.org
To unsubscribe send an email to notmuch-leave@notmuchmail.org

Thread: