How old a version of xapian should notmuch support?

Subject: How old a version of xapian should notmuch support?

Date: Sun, 13 May 2018 14:33:45 -0300



From: David Bremner

I'm looking at changes to get notmuch running with xapian-1.5
(developement version). One thing that has changed is the compact API we
are using (deprecated since 1.3.4, Jan 2016) has been dropped
[1]. Updating to the new version is easy enough, but maintaining support
for two versions is a bit boring.

One option is to bump the version of xapian required to run the next
release of notmuch. We could bump to 1.3.4, but since it's a development
version, for many users (e.g. on Debian) that means 1.4.0, which is
roughly two years old now.

From a Debian-centric point of view, now is about the right time to drop
support for the 1.2.x series of xapian; it's most recently available in
Debian Wheezy, for which the Debian long term support initiative will
end support at the end of this month (May 2018).

On the other hand, not everyone uses Debian. Travis is one place that
would require some work to get working (they're still using the _last_
LTS version of Ubuntu). 

We can of course continue to support 1.2.x.  It will increase the level
of ifdefication, especially if/when we try to support xapian-1.5+.

So how many people are actually using libxapian22? [2]

[1] I expect a few other changes will be needed to get notmuch working
properly with xapian 1.5; currently 11 tests fail.

[2] You can test via "ldd $(which notmuch) | grep xapian". If that says, you are using current xapian, and can ignore this
signature.asc (application/pgp-signature)
notmuch mailing list