Re: [PATCH 2/2] doc: add a hint about field processor support availability

Subject:Re: [PATCH 2/2] doc: add a hint about field processor support availability

Date:Thu, 20 Feb 2020 12:53:08 -0500

To:Tomi Ollila ,Jani Nikula ,notmuch@notmuchmail.org

Cc:

From:Daniel Kahn Gillmor


On Sun 2020-01-12 17:13:59 +0200, Tomi Ollila wrote:
> But, if we already made Xapian 1.4 minimun requirement in the next notmuch
> release, there XAPIAN_FIELD_PROCESSOR is always supported and all these
> conditionals could be removed (before even adding new)...

I'd support making Xapian 1.4 a minimum requirement in the next notmuch
release, particularly if someone does the work to provide a mostly-minus
patchset that cleans up the legacy conditionals.

fwiw, xapian 1.4 was part of debian oldstable (stretch), which was
released in mid-2017.  I don't think it's a problem to require a
dependency of that vintage.

         --dkg
signature.asc (application/pgp-signature)
_______________________________________________
notmuch mailing list
notmuch@notmuchmail.org
https://notmuchmail.org/mailman/listinfo/notmuch

Thread: