Re: bug#35370: notmuch-emacs: avoiding deprecated message-default-charset

Subject:Re: bug#35370: notmuch-emacs: avoiding deprecated message-default-charset

Date:Mon, 22 Apr 2019 10:21:25 -0400

To:Eli Zaretskii

Cc:notmuch@notmuchmail.org ,npostavs@gmail.com ,35370@debbugs.gnu.org

From:Daniel Kahn Gillmor


Hi Eli--

Thanks for the prompt followup!

On Mon 2019-04-22 09:33:26 +0300, Eli Zaretskii wrote:
> [dkg wrote:]
>> Do you have any recommendation for how an external emacs module (which
>> aims to work with at emacs 25 as well at least) should handle this?
>
> Just remove any uses of it.  Why are you using it now?

in notmuch's emacs/notmuch-maildir-fcc.el, as mentioned at the beginning
of this thread:

https://git.notmuchmail.org/git?p=notmuch;a=blob;f=emacs/notmuch-maildir-fcc.el;h=1551e8b649102ccdfecad9a2ef278949bfb3d702;hb=HEAD#l172

If we remove that entry from the (let) block, what are the implications
for users of notmuch who are still using emacs 25?

I don't have much knowledge in the way of deep emacs or message-mode
internals, so if there's answer that's obvious to you that you think i'm
missing, feel free to just point me to it.  Thanks!

   --dkg
signature.asc (application/pgp-signature)
_______________________________________________
notmuch mailing list
notmuch@notmuchmail.org
https://notmuchmail.org/mailman/listinfo/notmuch

Thread: